Recommended Configuration

Currently ProView is supported on the following devices:

  • iPad (tablet) - iPad 2, Mini, or newer (iOS 7.1 or greater)
  • Android (tablet) - Android 3.0 (Honeycomb), or greater. 7" tablets and larger
  • Desktop (Windows) - Windows Vista or newer
  • Desktop (Mac) - Mac OS 10.6 (Snow Leopard) or greater
  • Browser (not available in all markets) - Any OS/OS version where these browsers (or newer) are supported: IE9, Safari 5, Firefox 3.6, Chrome 12